Assistance with automating data entry prior to record creation

Hello everyone.

I’m having trouble figuring out. I’ve created the following automation.

It works, but only when the record is already created. How can I make the trigger for updating the field work while I’m filling in the information? I need to press “New record”, select a supplier, and based on this selection, other fields should be filled.

Also, I tried to create automation like in the screenshot above, but for some reason, in this case, I can’t access the related elements.

While doing the same thing in the previous automation, everything works fine. Why is that?

Here, automation should trigger when I select a supplier.

Hi - please describe the scenario you would like to achieve.

An automation can only run after the creation or after the update. It won’t run while you are still creating it in the first place.

This leads to a situation, where data is already present at creation or will be added after it. So its either triggered via “created” or “updated”. This way you may need to setup:

  1. a trigger when “created” to call the automation you wan’t to run
  2. a trigger when “updated” to call the automation you want to run
  3. the automation you want to run, when either 1. or 2. happened.

(Trigger for "created or updated" // OR allow multiple triggers)

I understand how record creation and update triggers work, that they operate within an already created record. My main question is whether automation can trigger at the stage of filling out a form before its creation.

I want data to be automatically filled in as I fill out the form to reduce the manual work for the manager when creating an application.

My second question is, I wanted to modify the automation so that when a form is created, the data is filled in. This is like screenshot 2, i.e., everything is the same as screenshot 1 but not upon update, but upon creation. However, for some reason, the automation is not providing me with the necessary applications, even though it did the first time.

I understand how record creation and update triggers work, that they operate within an already created record. My main question is whether automation can trigger at the stage of filling out a form before its creation.

Sorry if I missunderstand. They operate within an already created record. While you fill it out, its not yet created. Only after you save it.

My second question is, I wanted to modify the automation so that when a form is created, the data is filled in.

Your screenshot shows an automation, that is triggered by “when a record is updated” - not creation. If you want it to run right after you pressed save, its the “when a record is created” trigger.

Thats why it doesn’t run after you saved (“created”) the record in the first place. Its not an update!

I understand that there’s an update trigger and this automation is working.

I’m creating another automation based on the creation trigger, but for some reason, in the new automation, I can’t select the account application, as clearly seen in the screenshot.

In the automation triggered by updates under “My Companies - Accounts,” I can see them, but not in the new automation.

Regarding the first question, perhaps the project team could consider the possibility of triggering automation when filling out forms. This would greatly ease the manual workload for employees.

Here it doesn’t allow selecting the related application.

Although in the automation created earlier, it was selected.

And even if I create an automation exactly the same as the one that already exists and works, I still can’t select the application I need.


I also have another problem since the status fields are mandatory and cannot be handled differently. Consequently, the first value needs to be selected either by default or, as I planned, by setting up automation to assign a status upon saving the card. However, I cannot save the card because no value is selected, and again, this has to be done manually.

You should double check the relations. I don’t see the complete architecture and relations of your apps. But if the app doesn’t appear, there seems to be a missing link.

The first example is an outgoing relation, the other one starts from another app. Can’t check it.

Yes, you can only select one or use a template with a preset value when creating a record. You can then still let the automation change it.

Thats exactly as its currently designed to work.

How can it be missing if the structure hasn’t changed, and the first time I selected the applications in the automation, but the second time I can’t?

How to use a template with a preset value?
I haven’t found such a parameter.

@Venom I don’t see the structure of your apps. Also I can read some cyrillic letters, but its hard for me. As far as I see your screenshots the links are from two different starting points in your automations? Its not the same automation and relation, right?

All I know is, that the relations work pretty stable and reliable in automations. I’ve never seen Apps missing, that are linked via a field from one or the other app. Usually when I thought I had problems with it, I used the wrong direction for linking or the apps were not linked.


Look here - you can also set a template as default for the button as far as I know.

1 Like

Thank you for the advice; it’s one of the solutions. The only inconvenience is that all mandatory fields in template must be filled.

I don’t know how else to explain the problem to you.
You can connect via AnyDesk, and I can show you the automations and connections in the same applications in different cases, when sometimes they are there, and sometimes they are not.

Let’s try this: the structure of the applications hasn’t changed, nothing has been done except for the automation.

The problem is that I created an automation that works based on a field change trigger. As it turned out, it works perfectly when the card is saved and the field is changed. However, my task was to automatically populate fields depending on the user’s selection before saving the card. It turns out that it doesn’t work this way. The automation triggers on field change with a green dollar sign in the application.

Next, I tried to create an automation that would do the same thing upon saving the card, but I couldn’t replicate the settings that were there. The application wasn’t listed for me. I was very surprised and tried to create an automation that would be an exact clone of the first one, but again, I faced the issue that I couldn’t select the application I needed.

I’ve found what the problem is.

It turns out that the applications must be in the same workspace. If they are in different workspaces and linked together, you cannot select them in automation.

However, if you create an automation in the same workspace as the applications, and then move it to another workspace, the automation works correctly, but you won’t be able to replicate it.

1 Like