Data doesn't save into text field?

I’m, pretty sure its a very simple error on my side. I do some API Data pulling. While I can see the result in my console.log, it doesn’t store in a text field. Not sure why.

See the screenshot:

I also tried this way:

I even did lodash.escape…
I never achieved saving the data into the field.

What do I miss?

Ok… found the reason. Its a racing condition!

  1. step is a script execution
  2. when I added the delay, it worked
  3. creates the record


Shouldn’t the record creation wait for the script to finished in the step before? I can’t add delays here and everywhere? Is there anything I can do, that step 3 - even without delay, will wait for step 1 to finish?

I don’t know about your specific problem, but I think I always had to do:
calculation: your_array + “”

Hi Mario, I did cut it in the screenshot. Of course I add either values or calculations to the fields in “create record.”

However, the steps don’t wait to finish before starting the next one in an automation. That is an issue.