[DONE] Bulk Action on existing leads not completing full automation

I have an app with 489 items. Of these, 284 have a certain (single select) status marked and I want to run an automation for these 284 leads within this status.

I set the workflow trigger to be a “when a record is updated” but I set the filter to be IF Status = selected value.

Then I tried a Manual Run on ALL items to start the flow which would then find and execute on these 284 applicable items.

For some reason, the flow shows as if it’s running fine with successful results.

The Flow Count chart even increased tot he correct number expected
From 394 to 883

But the number of leads that properly moved over is only 67 and then stopped.
Tried clearing out those items from the new app, checking flows, and running again. Again had what looked like a successful run, but only 67 instead of 284 appear in my new app.

1 Like

Thanks for the report @CarsonRedCliffLabs,

we definitely need to understand that, I’ll get back to you with an update. Could be caused by the badged update logic we use for bulk operations.

Cheers and thanks again

1 Like

@Leo - for reference on this topic. I since tried it with a totally different approach and still had no success with the bulk flow.

For round two I set up my create item flow as a manually called flow.
Then I set a team view that was filtered for the 284 items that I wanted to trigger in bulk.
Lastly I set up a flow triggered with “On a scheduled time or interval” and had it run once at my chosen date. In that flow it got the view of filtered items and used the “call automation on collected” action to run the flow that creates the new item for these leads.

This approach also failed, bringing over only 23 of the desired 284, but the logs do not show any error messages.

@CarsonRedCliffLabs, thanks for the update! This definitely seems to be a bug. We will follow up and fix the problem as soon as we have identified the cause!

I’ll get back to you as soon as I have an update.


I’ve been able to work with @Tim via direct message to better identify and define this bug. The team at Tape jumped in and solved it with a fix so that the scenario is working as needed now.
Thanks so much for your ongoing collaboration, transparency, and support. I love Tape!