[DONE] Multiple Scopes Not Working (Issues with new API Feature - Zoom Integration)

Hi guys!

I love the new oAuth feature in the Automations tool, this is definitely going to make development a lot easier! I’m having a couple of issues building a Zoom integration and I just have a couple of questions.

  1. Please see this screenshot. I’m adding the redirect URI into Zoom but when I try to authorize, I get the following error message. https://paste.pics/PVSWL

  2. In the field where you add scopes, is it supposed to allow for a comma separated list of multiple scopes? The reason why I ask is because I add a comma separated list, the auth breaks, I go back in and the scopes are then separated by spaces instead, try to auth again, and then all but the first scope disappears.

1 Like

Hi @andrew.cranston,

first of all a very warm welcome to the Tape community. We are really happy that you are here! :tada: :100:

Glad you like the new OAuth feature and many thanks for the bug report. The problem with the scopes separator seems to be a bug that we are looking into.
We are also looking into the issue with the error when trying to connect to Zoom. Unfortunately, some services have to be specially handled by us in the background and the normal OAuth standard is not sufficient for these. We do not currently support these, but perhaps we have an issue and Zoom follows all standards.

I’ll get back to you here as soon as we have the first insights into your issues.

Cheers and thanks again for the report

1 Like

Welcome @andrew.cranston!
I just dived into the issue with the scope-parameter. There is indeed a bug when providing multiple scopes - thanks for reporting this. We will notify you here once the fix is live :slight_smile:

Regarding the screenshot you provided:
I just tried to integrate with zoom - at first I encountered the same issue as you did. However, after successfully adding and configuring an App in the zoom-marketplace (App Marketplace), I could successfully finish the OAuth2 flow.
It didn’t work for me until I had entered all the required details they ask for when adding the app.
Hope that works for you, too - let us know if you managed to finish the authorization or still encounter issues :slight_smile:

All the best,

@andrew.cranston the fix for the scope parameter is now live!
You can now (after refreshing your web client) provide multiple scope values separated with a colon within the oauth-integration inside the tape automations. Upon clicking “save” or “reauthorize”, the scopes should now get applied correctly.
Did this solve your problem?

1 Like

Hi Felix, I can confirm that the scopes bug has been solved by using semi colons instead. And yes, it seems that Zoom wants you to add the redirect URI to the whitelist as well as entering it in the redirect window, which I did and the connection is now active.

Thanks so much for all your help! I’ve been able to successfully build a Zoom integration and I will happily share it with the community as a showcase item :slight_smile: