[✅ Solution] Search across workspaces / permission issue

I have a search brick that searches a team members app.
I recently moved that team members app into a different workspace, The workspace is set to Private which is why I got the below error I believe:

Is there a way to search for a value within an app within a different workspace currently?

I also don’t know which ‘Actor’ has an id of 84907. How can I find this out? I’ve checked everybodys ID that is in the workspace and tried to modify the url when in somebodys record but it doesn’t work.

I guess my main question would be, when moving an app that already has automation associated with it what do I need to look out for to avoid errors?

1 Like

@Tim - Sorry to tag you directly but it would be really useful to know when moving an app that already has automation associated with it what I need to do to make sure the search and and other functions still work, if that is possible.

1 Like

@Martin_E - as you alluded, I would expect that your issue is related to the user who created or is conducting the search may not have access in the second workspace.

I just ran a quick test of looking for a value using search to a separate workspace and the flow returned a proper result with no issue - but I did have access to both spaces.

Have you tried deleting that search step and re-adding it now that the flow exists in a different workspace? Sometimes that is all it takes to ‘re-connect’ the data when things get moved between spaces.

1 Like

Yeah. Searching across workspaces does work fine. My main question is, as it’s so easy to drag and drop one app from one workspace to another I expected the automation to continue working flawlessly, so is that the recommended/only solution when an app is moved into another workspace, to go back through all the automation and reconnect everything?

The general rule of thumb is that an automation receives the permission of the user who last edited, i.e. saved it inside the workflow editor at the time of saving. If new workspaces are created afterwards, and an app that you perform a search inside is moved to that new workspace, it will not have proper permissions.

Subsequently, if you move an automation, or an app that the automation refers to, it should usually be sufficient to reopen and save the automation once - it will then receive proper permissions.

I hope that clarifies your questions. Let me know!


1 Like

That makes sense. Thanks for the clarification!

1 Like