[DONE] Import: Date field

Not sure if this is a known issue or if I am special :reminder_ribbon:

I’m in the process of importing data.
I am having the most issues with date fields and calculations

Firstly, calc fields cannot be imported “as-is”.
It would be ideal if we could pull them in as-is and then edit them after.
They are currently pulled in as a multiline text field or ignored.

Secondly, My date fields are erroring out. I think this is because I am in the US an out dates are formatted differently than the rest of the world :roll_eyes:

1 Like

@1F2Ns thanks for reporting this - indeed there was an issue with some Excel date formats not being parsed properly.

We just deployed a fix for this - could you retry and make sure your import of the date column works well now? It should also respect your timezone etc and yield proper data inside Tape. Let me know if it worked!

Regarding calculation fields: You can only import their values, obviously not their formula. So importing them does probably not make a lot of sense, if the value is derived from other fields. If you provide more info on the context, I may be able to assist you in solving your case. :rocket:

Happy importing & great day to you

1 Like

@1F2Ns just to make sure this does not fall through the cracks - did the fix work for you? Please do let us know if the import issue persists, or whether it was already resolved. :innocent:

Crap. Yes, it worked flawlessly.


It still gave me a ‘dummy’ warning about data loss BUT I did not have any issues.
Only thing I see worth mentioning is the date/time format.

I’m in the USA and we format as mm/dd/yyyy
Because I sort lots of data like this format better: yyyy/mm/dd because it keeps everything sorted by year and month. Because I am thinking about this now, the ability to format dates/times would be a fancy little feature. Just a thought :grin: https://momentjs.com/

1 Like

I see a benefit to having the ability to select a calc field when importing and creating a new app. This way after import, all of the data in is there (not working, be existing), and I only have to reformat/remap it.

As is, I have to skip those fields when importing a new app, add the calc fields after creation. Only then can I C&P my data over into the app. I hope that makes helps to explain a bit better for you.

1 Like